Failed to retrieve directory listing

Apr 4, 2011 at 8:19 PM

Any thoughts on the following?

My Role Settings are set to the following:

-DiagnosticsConnectionString: UseDevelopmentStorage=true
-AccountKey: (Storage Account PrimaryAccess Key)
-AccountName: (Storage Account Name)
-Mode: Live
-Base Uri: [blank]
-Use HTTPS: true
-Use Async Methods: true 


Response: 220 FTP to Windows Azure Blob Storage Bridge ReadyCommand: USER kedwards

Response: 331 User kedwards logged in, needs passwordCommand: PASS ****

Response: 220 Password ok, FTP server readyStatus: ConnectedStatus: Retrieving directory listing...Command: PWD

Response: 257 "/" PWD Successful.Command: TYPE I

Response: 200 Binary transfer mode active.Command: PASV

Error: Disconnected from server: ECONNABORTED - Connection aborted

Error: Failed to retrieve directory listing



Apr 5, 2011 at 11:00 AM

Hi Edwardsk2003,

I think the clue is in the FTP chatter at the bottom - "Command: PASV", which means you are connecting in PASSIVE mode which is not supported on Windows Azure. You need to swap your FTP client to ACTIVE connection mode in order for it to succeed.

Can you check your connection settings and let me know how you get on? Also, what FTP client are you using?



Jan 23, 2012 at 3:39 PM


I'm running into this same issue, but using active mode this time:

Status: Resolving address of

Status: Connecting to myappsip...

Status: Connection established, waiting for welcome message...

Response: 220 FTP to Windows Azure Blob Storage Bridge Ready

Command: USER myuser

Response: 331

User myuser logged in, needs password

Command: PASS *********

Response: 220 Password ok, FTP server ready

Status: Connected

Status: Retrieving directory listing...

Command: PWD

Response: 257 "/" PWD Successful.

Command: TYPE I

Response: 200 Binary transfer mode active.

Command: PORT 80,86,117,2,5,74

Response: 200 PORT command succeeded

Command: LIST

Response: 150 Opening data connection for LIST

Error: Connection timed out

Error: Failed to retrieve directory listing


I am 100% certain that the account name and key in ServiceConfiguration.cscfg are correct (as i quadruple-checked), and Mode is Live.

Any ideas ?


Thank you,


Feb 1, 2012 at 11:47 AM



Did you try to set the TCPKeepAlive on the TCP socket ?

it's work for me :



Feb 9, 2012 at 1:03 PM

Nope, didn't work.

I'm still having this problem.

May 21, 2012 at 11:08 PM

I'm noticing this as well.  Taking the Beta v0.2 release and running in Windows Azure did not work.  I also tried the latest source code and latest (1.6) SDK and ran that in Windows Azure - same problem.


Any ideas on what's going wrong with the LIST command?

Jun 20, 2012 at 4:56 PM
Edited Jun 20, 2012 at 4:58 PM

I spent past few days using this project as base for my FTPS implementation. I feel like I should say something about this issue:)

After the client is successfully authenticated with the server, but before anything else happens, the client and the server agree on who will be initiating the data channel.

In active mode, the client issues a PORT command to the server, providing the server with the local IP address and port number from dynamic range.

The server then will try to connect to the client on that IP with that port.

Herein lies the problem: if your machine is behind an old router or any NAT device it is possible that you are not able to receive incoming traffic on that port.

If you are using FileZilla, use the network wizard's test to determine if you can receive incoming connections:) (Edit>Network Configuration Wizard..->Go through steps->Run Test)

For a test you can set up your router to map all traffic on ports 3000 - 7000 to your machine and test what happens then.

Let us know how it goes;)

Jun 22, 2012 at 2:44 AM

I'm having this issue and I tried the test you mentioned in filezilla and set the ports to 6000 - 6100 and forwarded them to my machine. Made sure filezilla was in the firewall settings and i get this. 

Connecting to
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.5.3
Response: 230 logged on.
Checking for correct external IP address
Retrieving external IP address from
Checking for correct external IP address
IP "MYIP" ha-bii-ceb-ja
Response: 200 OK
PREP 6018
Response: 200 Using port 6018, data token 80778104
Connection timed out.
Connection closed