Failed to retrieve directory listing (bis)

Jul 24, 2012 at 12:59 AM

Hello Richard an others,


I'm writing you this post because I met some difficulties to deploy the ftp2azure solution on a production Azure environment.

At the beginning, I was thinking it was from my own customization in your code, so I tried to understand the reason. As I didn't find, I have decided to upload directly the ftp2azure package without any modification, except, of course, the .cfcfg to configure the storage account.

Then I tried to connect to the ftp with filezilla from my compter, configure with these parameters :

Active Mode : checked (and set to be always in active mode)

Limited ports : 50000 to 50100

Using to get my external ip


I can connect to the ftp serveur but then, I have an error during the LIST command :

Status:	Connection established, waiting for welcome message...
Response:	220 FTP to Windows Azure Blob Storage Bridge Ready
Command:	USER david
Response:	331 User david logged in, needs password
Command:	PASS ****
Response:	220 Password ok, FTP server ready
Status:	Connected
Status:	Retrieving directory listing...
Command:	PWD
Response:	257 "/" PWD Successful.
Command:	TYPE I
Response:	200 Binary transfer mode active.
Command:	PORT 86,217,52,209,195,80
Response:	200 PORT command succeeded
Command:	LIST
Response:	150 Opening data connection for LIST
Error:	Connection timed out
Error:	Failed to retrieve directory listing

I tried to open ports and redirect them from my router to my computer but it's same. 

Do you have any idea of the source of my problem?

I can give more information if needed.


Thanks a lot.



Jan 17, 2013 at 9:36 PM

Hi David

I'm sorry you didn't get a quicker response to help you with this - and unfortunately no other community responses either! Have you found the root cause of your issue?