Unable to display blobs

Jul 7, 2012 at 1:34 AM

Hi, im triying to use this code but i can´t obtain the blobs of a container.

I'm obtaining this error in Filezilla

Conectando a 70.37.57.51:21...
Estado:	Conexi�n establecida, esperando el mensaje de bienvenida...
Respuesta:	220 FTP to Windows Azure Blob Storage Bridge Ready
Comando:	USER test
Respuesta:	331 User test logged in, needs password
Comando:	PASS ****
Error:	No se pudo conectar al servidor

 

Im triying whit an active connection.

The code i have modified is this in ServiceConfiguration.cscfg:

<Setting name="AccountKey" value="ZoTIzMtq/0vJm52QxnS/P2iWdn6HxxxxxxxAHw3x7I5mxArUSeW4mXfO12+0GaHEZ/6/gHhbAUybHg==" />
      <Setting name="AccountName" value="ficpublicblob" />

And the code in AzureFileSystemFactory.cs:

string containerName = "pdfs";

            // TODO: Put your authentication call here. Return NULL if authentication fails. Return an initialised AzureFileSystem() object if authentication is successful.
            // In the example below, to demonstrate, any username will work so long as the password == "test".
            // Remember: you can plug in your own authentication & authorisation API to fetch the correct container name for the specified user.

            #region "REPLACE THIS WITH CODE TO YOUR OWN AUTHENTICATION API"
            #endregion  

            var system = new AzureFileSystem(sUser, sPassword, containerName, Modes.Debug);
            return system;

Could you give me a han with this?

Coordinator
Jan 17, 2013 at 9:36 PM

Sure - doesn't look like you've actually implemented any authentication code per the comment:

#region "REPLACE THIS WITH CODE TO YOUR OWN AUTHENTICATION API"
#endregion 

Have you checked that sUser and sPassword, together with containerName variables are set to values matching your blob storage account?